Hello Guest

Some Projects Not Loading.. [Its a 3rd party AU issue]

  • 20 Replies
  • 3745 Views
*

KING

  • ***
  • 109
    • View Profile
Some Projects Not Loading.. [Its a 3rd party AU issue]
« on: November 05, 2017, 06:34:21 PM »
Hey j,


I have just come across a couple of projects (out of many) that haven’t been opened in a while, (one from August 2017) but they get stuck trying to load an effects node.
I have no idea what the effect(s) are (AUM in-built or otherwise) or if I have deleted them from my iPad etc..

It gets to the blue spinning circle and no further. Never had AUM behave like this before.
No matter how long I leave it, (20 mins) it won’t load. I have found two projects that do this so far..

Done all the reboot shizzle..

Assistants needed!

Cheers,

King

..



« Last Edit: November 18, 2017, 02:57:01 AM by KING »
:-)

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #1 on: November 06, 2017, 12:01:10 PM »
This can be caused by projects that uses IAA or AUv3 nodes that are expired testflight beta versions still installed on your device. See if you have any effect apps installed that won't open when you launch them manually from the home screen, and if so - delete them.

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #2 on: November 06, 2017, 04:11:04 PM »
Nah!
 iOS 11 apps and none expired betas.. I did just check again.. only NanoStudio, which would have never been used in AUM.

I feel the only way is to somehow send you a copy of one of the projects?
If yes, please instruct. I can access it from the files app etc..

King
« Last Edit: November 06, 2017, 04:14:54 PM by KING »
:-)

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #3 on: November 06, 2017, 04:40:19 PM »
Nah!
 iOS 11 apps and none expired betas.. I did just check again.. only NanoStudio, which would have never been used in AUM.

I feel the only way is to somehow send you a copy of one of the projects?
If yes, please instruct. I can access it from the files app etc..

King

Sure, just email me one of the projects. Either from the Files app or from AUM itself by long-pressing the session in the files menu.

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #4 on: November 06, 2017, 04:55:48 PM »
Ok sent, to lijon.. address.

See, you also reminded me about the functions in long press.

Anyway looking forward to your reply! ????????

King
:-)

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #5 on: November 07, 2017, 12:16:11 PM »
So, I got your project and could do some investigations..

It froze on the AUVoiceRackFX plugin while restoring its state. I then updated to the latest version of AUVoiceRackFX and it worked!

PS. No reason to hang on to 11.0.3 as far as I know, 11.1 fixes several issues.

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #6 on: November 07, 2017, 05:18:06 PM »
So, I got your project and could do some investigations..

It froze on the AUVoiceRackFX plugin while restoring its state. I then updated to the latest version of AUVoiceRackFX and it worked!

PS. No reason to hang on to 11.0.3 as far as I know, 11.1 fixes several issues.

Cheers for looking into this for me.

I’m on the latest version of VoiceRack = 2.0.3. (Currently in the AppStore).
What’s your version?

King

:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #7 on: November 07, 2017, 05:18:48 PM »
Regarding iOS: although I’m on 11.0.3, I’m not really a frequent ios updater.
The only reason I upgraded from 11.0.2  was because of battery drain, - my fingers and toes were crossed and 11.0.3 fixed it.
I have been tempted to update to 11.1 because of this new (to me) crackle n pop when app switching.

Can you tell me any info regarding battery on 11.1 vs 11.0.3?

Cheers,

King

Added: I only just in the past couple weeks updated from 10..
« Last Edit: November 07, 2017, 05:24:23 PM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #8 on: November 07, 2017, 06:12:53 PM »
I deleted VoiceRack.
AUM does the same thing.

I re-downloaded VoiceRack.
AUM does the same thing.

Rebooting in between etc..

King
:-)

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #9 on: November 07, 2017, 06:58:23 PM »
Yes, VoiceRack 2.0.3 was what I updated to.

Perhaps there are more AU's that for some reason isn't working or restoring their state properly. Try making sure that all your AU's are up to date.

Also, it might be bugs in iOS 11.0.3, there has been several fixes in 11.1.

Sorry, I have no data about battery performance in 11.0.3 vs 11.1.

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #10 on: November 07, 2017, 07:19:19 PM »
All AU's a 100% up to date!



Perhaps there are more AU's that for some reason isn't working or restoring their state properly.

Please dont take it the wrong way, but this is why I sent you the project. :)
I have no way of drilling down any further.
You said it’s was VoiceRack, I’m unsure how you got that, but I deleted it.



11.1 should be my very very last option. If it was not available what else can you do?

Are you able to load the project fully, maybe that’s what I need to know?

Cheers,

King

« Last Edit: November 07, 2017, 07:41:53 PM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #11 on: November 07, 2017, 07:23:01 PM »
Concerning the forum: I have just had to re-write the above comment.

The forum will show that you are logged in, but when you press “post” there is an error and you/we have to log in again, (with no saved comment data). This is when one have been away for a while.
Also this has happened a number of times in the past, but I didn’t report it, as they were short posts.

King
« Last Edit: November 07, 2017, 07:27:20 PM by KING »
:-)

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #12 on: November 07, 2017, 08:01:03 PM »
All AU's a 100% up to date!

Ok! Then it's only iOS itself that's not up to date.

Quote
Please dont take it the wrong way, but this is why I sent you the project. :)
I have no way of drilling down any further.
You said it’s was VoiceRack, I’m unsure how you got that, but I deleted it.

11.1 should be my very very last option. If it was not available what else can you do?

Are you able to load the project fully, maybe that’s what I need to know?

Yes, I could load the project without it freezing on any AU. But then, I don't have all plugins you used in it: Remaster, Bark Filter, QuatroMod. So, the only AU's in your project that I have is Replicant 2 and VoiceRack. And of course I can't load the FilePlayers, since I don't have your soundfiles.

You could delete Remaster, try loading the project. Then delete Bark Filter, try loading it again. If working, re-install Remaster. If still working, re-install Bark Filter. etc..

Unfortunately, a bug in iOS 11 makes it impossible for the host to recover if an AU fails to load in some cases. Another example is when the AU is an expired beta version.

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #13 on: November 07, 2017, 08:08:55 PM »
Update: I tried installing Remaster, and the project freezes when trying to load it. Actually, Remaster fails to load also when starting on a fresh project. So, what you can do is delete Remaster and ask their devs to fix it!

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #14 on: November 08, 2017, 12:22:01 AM »
Ok I’ll look into it/those.

One last thing, what is the plugin that is trying to load on track 4 (I believe) which I renamed to “Yo”?
That’s where it seems to be stuck. Is it VoiceRack or..?

Appreciate the Support Jonatan,

King
« Last Edit: November 08, 2017, 12:41:02 AM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #15 on: November 08, 2017, 02:21:15 AM »
No worries, found it!

Remaster!
(Been meaning to replace all instances with zMors eq) :/

I used the new 'Offload App' feature in iOS 11.
I did use it with VoiceRack earlier, but it wasn’t the culprit, so lost it’s data when I fully deleted it, but it’s cool.

I had a feeling it was Remaster after you mentioned it, as I have never been able to load it in Auria Pro, and I emailed Remaster developers about it a long while ago when AP started to support Audio Units. (Can’t remember what they said offhand)

Glad I didn’t have to update iOS just for this..

I’ll get back in touch with the devs and update this thread if they sort it etc..

Cheers again, without the list of plugins you gave (which would have been my next question - 'then you sent the list), it would have been mind explode!

Cheers,

King
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #16 on: November 08, 2017, 03:58:39 AM »
Email from Remaster developers: (2:56am - 8-11-2017)

“Hi King,

Remaster is due for an update.
Working on it. Not sure when it’s done though.

T”

___

King
« Last Edit: November 08, 2017, 02:49:54 PM by KING »
:-)

Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #17 on: November 08, 2017, 09:20:37 AM »
Great!

Yeah, perhaps I should make AUM display a temporary label with the AUs name above it while loading, in case it freezes. Then at least the user knows which plugin it is. Alternatively, show the icon and the progress animation on top of it somehow (would need to tweak the design).

I still recommend 11.1, it's better than 11.0.3 as far as I know.

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #18 on: November 08, 2017, 02:46:41 PM »
Great!

Yeah, perhaps I should make AUM display a temporary label with the AUs name above it while loading, in case it freezes. Then at least the user knows which plugin it is. Alternatively, show the icon and the progress animation on top of it somehow (would need to tweak the design).

I still recommend 11.1, it's better than 11.0.3 as far as I know.

“AUM display a temporary label with the AUs name above it while loading,”

Whilst all this was happening, I was thinking the exact same thing!

This was quite a biggie, in terms of the affect which was a total freeze! Never had AUM do anything like this before, it was an eyebrows meeting event. :)
The great thing though is that it was nothing to do with AUM, so my feelings towards it have not been altered.

:-)

King
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Projects Not Loading.. mini2 - 11.0.3
« Reply #19 on: November 08, 2017, 02:57:10 PM »
Update: I tried installing Remaster, and the project freezes when trying to load it. Actually, Remaster fails to load also when starting on a fresh project.

Funny!
I must have read this part so fast (in between the BM3 forum) that I hardly even remember reading it. But it’s also almost word for word what I wrote to the developers haha :-)
Twilight Zone-ish.. ;)

Re-reading it, it must have been the word “tried” that threw me :)

Best,

King
« Last Edit: November 08, 2017, 03:00:06 PM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Some Projects Not Loading.. [Its a 3rd party AU issue]
« Reply #20 on: November 20, 2017, 02:22:36 AM »
Son of a gun!

Update in the store for ‘Remaster’, didn’t think twice and updated. Flipping AppStore updates bug at work again. This update was for 1 year ago. :/

I have a few in my updates list with the same issue, and have left them there, un-updated, but thought they (Remaster) may have been on the case..

Oh well, it’s the same version I already had so no change in the loading of project that include it.

King
:-)