Hello Guest

Buffer Size! [Request]

  • 9 Replies
  • 2168 Views
*

KING

  • ***
  • 109
    • View Profile
Buffer Size! [Request]
« on: December 03, 2017, 01:54:15 PM »
With the new Rozeta suite, I’m ‘now’ having to constantly adjust the Buffer size for various project (with or without Rozeta) (old and new)

Earlier I loaded up a project (with Rozeta) and was startled by the loud white noise and audio echoing/glitching and fading out - ‘I had to ‘quickly’ close out of AUM’.
...The buffer was set to 1024, because I was using that for Model 15 in a previous session. So I set it back to 256, and all is well.
“I’m not sure I can keep remembering to set it back n forth for various projects though”.  :)

So is it possible for AUM to state-save the buffer size with individual projects?

___

256 would need to be the default, but also when one presses the ’Clear’ button.
Or an option to choose (some may want 1024 or 512 etc, as default).

Cheers,

___

King
« Last Edit: December 03, 2017, 02:40:47 PM by KING »
:-)

Re: Buffer Size! [Request]
« Reply #1 on: December 04, 2017, 03:07:31 PM »
I don't think switching buffer sizes automatically when loading projects is a good idea.
Currently it remembers the last preferred buffer size and tries to use the same setting.

Getting loud noises because of a large buffer size makes no sense, that must be a bug in one of the hosted apps. Rozeta does not make any sound by itself so perhaps check the other apps and see if any of them does not work at 1024 frames, and notify their developers!

*

KING

  • ***
  • 109
    • View Profile
Re: Buffer Size! [Request]
« Reply #2 on: December 04, 2017, 07:09:43 PM »
I’ll find the culprit n update thread.

I mentioned Rozeta, as Brambos said I should use 256-512, can’t remember why..
I’ll check my emails later and see what we were discussing..

Cheers,

King
« Last Edit: December 04, 2017, 07:13:06 PM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Buffer Size! [Request]
« Reply #3 on: December 04, 2017, 07:21:13 PM »
“...and see if any of them does not work at 1024 frames, and notify their developers!”

___

15-11-2017

I said:
“I’ve so far played around with the Arp, Bassline and Rhythm. All is working, however I’m finding it’s not perfectly in constant sync with AUM' metronome click.

Testing with 'Rhythm' and Ruismaker, just playing a straight 4x4 120bpm (kick n snare) it drifts in and out by milliseconds. Sounds like every so often a note is out, not so much a whole pattern. “

___

He said:
“You're not imagining things. You may have also heard that the 'jitter' is less when using smaller buffer sizes in AUM.
It's a known quirk of how AUM implements MIDI handling (in order to minimize latency). I know Kymatica are going to change this in an update soon and then my plugins will play accurate to the nanosecond ;-)

For now I recommend keeping the buffer as low as you can afford for the best timing accuracy.”

___

I said:
“Yeah I’ve heard and experienced the M15 thing. Seems I’ll have to keep an eye on the buffer until AUM updates etc..
Loading a project with m15 must have triggered it, or I was messing with the buffer at some point and left it at 1024. Just set it to 256 and boom. ”

Etc..

King

« Last Edit: December 04, 2017, 07:26:05 PM by KING »
:-)

Re: Buffer Size! [Request]
« Reply #4 on: December 05, 2017, 12:25:37 PM »
That's right, lower buffer sizes gives less latency and currently less MIDI timing jitter. (Improving this is at the top of AUMs todo list). However, it does not explain why M15 would need 1024, or why any other plugin would generate weird noises at 1024.

*

KING

  • ***
  • 109
    • View Profile
Re: Buffer Size! [Request]
« Reply #5 on: December 05, 2017, 12:50:46 PM »
“However, it does not explain why M15 would need 1024, or why any other plugin would generate weird noises at 1024.”

Indeed!

With Model 15 Audio Unit (depending on iPad and chosen preset) some folks are not able to get more than one instance of M15 without issues.

For me ‘mini2’ I can just get an instance with the default preset ‘Zowwpad’ and the DSP being in the 90’s and above (this is when buffer is less than 1024).
@ 1024 I’m getting approximately 20% ‘lower’ DSP.. :)

___

I’ll have to get back to you on the weird noises thing...

___

King
« Last Edit: December 05, 2017, 12:54:33 PM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Buffer Size! [Request]
« Reply #6 on: December 05, 2017, 01:29:07 PM »
I’ve found the buffer-bugger!

It’s bs-16i. It does not like 1024 (in this project at least).

Yeah, I know, email, developer etc. Feel like I’m in a loop, emailing and posting always trying to get the best for everyone (including me) :)

I already emailed them the other week, about some other issues (some notes-off not working on some of the presets) and other things.
Have not received a reply as yet.

If I’m emailing to try and help/report bugs and I don’t get a reply, then I tend not to email that party anymore. (I’ll usually  send one more saying - “Hallo”) then that’s it..
A lot of people would be amazed at the amount of changes and feature requests that have been added because of my emails (quite a few) - I’m not the only one! :)
I Love this music making environment too much.
But I’ll leave it to others, it’s slowing me down .. :-)

The above is not a rant, just some history.. :-))

___

I need to just get back to making music.. That’s where my talents are (and my wages!)

King

« Last Edit: December 05, 2017, 01:42:23 PM by KING »
:-)

Re: Buffer Size! [Request]
« Reply #7 on: December 05, 2017, 01:37:35 PM »
I'm sure the bs-16i devs appreciate when users find bugs! I know I do :) Sometimes it's hard to keep up with incoming mail, or keeping it organized and not forgetting to reply, etc.

*

KING

  • ***
  • 109
    • View Profile
Re: Buffer Size! [Request]
« Reply #8 on: December 05, 2017, 01:52:56 PM »
I'm sure the bs-16i devs appreciate when users find bugs! I know I do :) Sometimes it's hard to keep up with incoming mail, or keeping it organized and not forgetting to reply, etc.

I know! I can and can’t imagine lol.

Main thing with me, if I don’t get a reply, I’m not sure it’s going to the correct department/email addresst (if any)..
So, deaf ears and all that..

Then there are guys like you, who are on it.
And I know at least your seeing/considering.

I did a lot less reporting (and more music) when I was using BM2 and NanoStudio on my iPhone 4, less apps. (Pre-iPad) ... But I like to help! “Catch 22”

It’s also the main reason I no longer comment on the Audiobus forum, tooooooo time consuming...
It’s enough just reading it daily lol.

...

-Note to self: “Make Music !!!”-

___

King

« Last Edit: December 05, 2017, 02:02:24 PM by KING »
:-)

*

KING

  • ***
  • 109
    • View Profile
Re: Buffer Size! [Request]
« Reply #9 on: December 07, 2017, 07:58:26 PM »
The Developer of bs-16i must have been reading this thread..

Got a reply, and sent over the info regarding the 1024 buffer issue.. We'll see..

(I did send a little p'ed off email yesterday though, so that may have shook em..)

___

King
« Last Edit: December 07, 2017, 08:01:22 PM by KING »
:-)